Update to Sending Email Address for Support Ticket Responses
Incident Report for Rainforest API
Resolved
This incident has been resolved.
Posted Apr 16, 2024 - 19:38 BST
Investigating
We’ve uncovered an issue with our email domains used for Customer Support. Our team currently has a ticket in for investigation. You may see responses from our Support team coming from the email address support@trajectdata.com in the meantime. We look forward to serving you!
Posted Apr 04, 2024 - 20:51 BST