Parsing Issue
Incident Report for Rainforest API
Resolved
This incident has been resolved.
Posted Apr 24, 2023 - 04:00 BST
Identified
Author page parsing is currently operating in a degraded state where the 'titles' field is not being parsed.

Rainforest API apologise for the inconvenience caused during this incident.

Our team, based in the UK and online between 9am and 5:30pm GMT Monday to Friday, are working on a resolution as quickly as possible.

As Rainforest API sources data through public web-scraping parsing issues such as this can occur (albeit rarely) when page layouts change or when the underlying website is down for maintenance.

You may use the 'skip_on_incident' request parameter to instruct Rainforest API to not serve you requests when a parsing incident such as this is detected. For example, requests made with 'skip_on_incident=all' or 'skip_on_incident=major_only' will refuse requests when any, or just a'major', incident occurs for the affected API component. This can be desirable if your system is making unsupervised requests to the API that you would like to gracefully fail in the event of an incident.

In addition any Collections started during this incident will be queued and automatically started once the incident is resolved.

We will post further updates, including an estimation on resolution time, when available, thank you for your patience.
Posted Apr 23, 2023 - 15:24 BST
This incident affected: Parsing Status (Author Page Requests).